error on iphone and ipad browser

Q&A about the latest versions
Post Reply
wiso
Posts: 106
Joined: Wed Oct 26, 2016 6:52 pm

error on iphone and ipad browser

Post by wiso » Sun Jan 07, 2018 4:57 pm

good evening,
i made a virtual tour which works fine on pc in every browser.

on iphone and ipad there only some panoramas work. some others there is a error message that there is an error and the website has to be loaded new - and jumps back to the former website. (android/chrome it works fine)

the only different in between the panoramas which are working and the others which does not isthat the "bad ones" have picture hotspots.

knows anyone this problem?

thank you,
wiso

User avatar
Hopki
Gnome
Posts: 7754
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: error on iphone and ipad browser

Post by Hopki » Sun Jan 07, 2018 8:02 pm

Hi wiso,
New one on me.
How large are your popup images?
Make a copy of the project file and in the cop delete the image hotspots.
Does it then work?
If so can you send me some of your pictures.
Regards,
Hopki

JSchrader
Posts: 107
Joined: Sat Nov 28, 2015 2:26 pm

Re: error on iphone and ipad browser

Post by JSchrader » Mon Jan 08, 2018 1:59 pm

Might be a performance issue.
Had this recently with a tour that has video hotspots where the nodes with those hotspots will crash and restart the browser on my iPhone.
On my iPad mini 4 these work though.

wiso
Posts: 106
Joined: Wed Oct 26, 2016 6:52 pm

Re: error on iphone and ipad browser

Post by wiso » Fri Jan 12, 2018 11:27 am

hallo again,

i tried the following:

first i saw that there was a big photo with 4000 kb included. i downsized it. now i have 5 photos with apr. 400kb each for the photo hotspots.

but did not work - browser on iphone and ipad crashed.

then i converted all photo hotspots to png. but dthe same, did not work.

then i deleted all picture hotspot - that works ...

what can i do to show the site on ios correctly?

best regards
wiso

User avatar
Hopki
Gnome
Posts: 7754
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: error on iphone and ipad browser

Post by Hopki » Fri Jan 12, 2018 12:23 pm

Hi wiso,
Can you send me your complete project as I not having any problems with this and I know if this was an issue with Pano2VR I would be getting lots of complaints.
Send to support@ggnome.com
Go to the help menu and support package, make sure you select input images and skin.
Regards,
Hopki

User avatar
Hopki
Gnome
Posts: 7754
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: error on iphone and ipad browser

Post by Hopki » Sat Jan 13, 2018 12:02 am

Hi wiso,
Found that the pinned images have been added to Pano2VR with the wrong size setting.
Example: Gruppe3_Gesetzexx.jpg, its actual size is 992 x 702px.
The size that has been set in Pano2VR for this image is: 4,961 x 3,508px.
All your pinned images are the same with the size way larger then the image.
This is why its crashing mobile devices.

Select the pinned image in the image viewer mode and set the size to the actual size of the image.
You need to do this with all pinned images.

Also you have pictures in the skin that you have left as default type which is PNG.
Example: image_adler.png which is 3.6MB in the images folder.
Once set to JPEG and published the image is changed to 634KB with no visible difference.

Images with transparency are the only ones that should use PNG, but pictures with many colours should be JPEG.
This will cut down file size and load times.
Regards,
Hopki

wiso
Posts: 106
Joined: Wed Oct 26, 2016 6:52 pm

Re: error on iphone and ipad browser

Post by wiso » Sat Jan 13, 2018 1:00 am

thank you hopki,
i learn more and more about the programm...

the difference of the two sizes occured probably that i made the first design with big pictures and replaced them afterwords with smaller ones...

thank you for your help,
best regards,
wiso

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests