Toggling Map Issue

Special forum to share and discuss skins for Pano2VR and Object2VR
Post Reply
User avatar
keith@fachwen.org
Posts: 92
Joined: Tue Aug 28, 2012 11:34 am
Location: North Wales
Contact:

Toggling Map Issue

Post by keith@fachwen.org » Sat May 13, 2017 12:01 pm

Lately some of my older panos seemed to develop some issues with Toggling the Google Satellite Map on and off, and dragging the pano on iPads and iPhone stopped working too.

At some point the map would stop showing up after repeated off and ons. I first noticed this on an iPad, but was reproducible on Safari on a Mac too. So I dug into the skin, which I hadn't edited for some time. All seemed well. The toggle mechanism / logic was identical to that used for the thumbnails strip, originally copied from Hopki I think.

So I suspected something had changed at the Google Maps end of things as it used to work fine.

One thing I came across in the skin was a setting in the Map section of the skin Unload Map on hide. This box was checked, so I un-checked it, and the skin started to work properly again:

Unload Map on hide.png
Unload Map on hide.png (34.5 KiB) Viewed 382 times

Anyone else experienced anything like this?

Thanks.

User avatar
Hopki
Gnome
Posts: 7552
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: Toggling Map Issue

Post by Hopki » Sun May 14, 2017 9:33 pm

Hi Keith,
Will need to check this out but the unload map check box was so if you zoom in etc and close and open the map, the map opens with the view reset.
Other wise it will open as you last left it.
Do you ave a URL of a tour that does this?
Regards,
Hopki

User avatar
keith@fachwen.org
Posts: 92
Joined: Tue Aug 28, 2012 11:34 am
Location: North Wales
Contact:

Re: Toggling Map Issue

Post by keith@fachwen.org » Mon May 15, 2017 12:10 pm

Hi Martin,

Seems to be definitely reproducible. Here are 2 identical outputs, the only difference the Unload map on hide is switched on or off.

In this tour it's unchecked, all works fine no matter how I switch the map on or off or play with the other buttons
http://www.fachwen.org/panos/041204-fin ... index.html

Same tour, with Unload Map now checked, it's very easy to break, pop out the tool bar in the bottom right to start.

Breaks if I use the next or previous buttons next to the I, then try and switch the map on or off.

Breaks if I click on the map hotspots themselves, this happens on the desktop or the iPad (using Safari on a Mac) Map stops appearing and I can't control the panorama (lack of control only seems to happen on the iPad).
http://www.fachwen.org/panos/output/

Separate issue: example of dragging not working on iPad with an old skin, map not involved here, but this goes away if I re-author in the latest Pano2VR
http://www.fachwen.org/panos/060304-penllyn/index.html

User avatar
keith@fachwen.org
Posts: 92
Joined: Tue Aug 28, 2012 11:34 am
Location: North Wales
Contact:

Re: Toggling Map Issue

Post by keith@fachwen.org » Mon May 15, 2017 12:36 pm

Mmm.. another one that mis-behaves, on the iPad only:
http://www.fachwen.org/panos/170419-bigil/
The toggle switch is off in the skin here, but if I pop up the map and click on the hotspot on the map, the map button stops working...

This one stops woking if I click on the hotspots on the map as well, Unload map on hide is off too.
http://www.fachwen.org/panos/160524-lodge-dinorwig/

So something wrong with my Skin I think!! I'm hoping to use the same skin on all similar projects over time.
Here are the skin and template files:
uploads.zip
(70.05 KiB) Downloaded 14 times

User avatar
keith@fachwen.org
Posts: 92
Joined: Tue Aug 28, 2012 11:34 am
Location: North Wales
Contact:

Tracked down the issue...

Post by keith@fachwen.org » Sun May 21, 2017 11:00 am

But not sure how to fix it.

My skin has a special silhouette 'map marker', I got this from Martin in the past, it's the "layer_marney" skin. Here it is in the skin editor:

skin.png
skin.png (45.03 KiB) Viewed 319 times

If I use this and click on the hotspots in the map:

silouete.png
silouete.png (94.09 KiB) Viewed 319 times

Then the map will stop opening when I click on a button to open it or close it. This happens in the original unmodified skin too.

If I delete the map marker from the skin, then the map markers revert to normal:

standard.png
standard.png (107.93 KiB) Viewed 319 times

No mater how often I click on these in the map, my hide/show map button works fine.

Some help in getting the silhouette map marker to work would be great :D

Here is a video of the "fault" in action...

fault in action.mp4
(9.52 MiB) Downloaded 13 times

User avatar
Hopki
Gnome
Posts: 7552
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: Toggling Map Issue

Post by Hopki » Mon May 22, 2017 2:43 pm

Hi Keith,
Looks like a bug, I have reported it.
Looks like it crept in with version 5.1.
5.0.3 was working fine.
Regards,
Hopki

User avatar
keith@fachwen.org
Posts: 92
Joined: Tue Aug 28, 2012 11:34 am
Location: North Wales
Contact:

Re: Toggling Map Issue

Post by keith@fachwen.org » Mon May 22, 2017 5:11 pm

Ok, thanks for checking it out. Hope it gets fixed reasonably soon :D

Interesting that the Layer Marney example https://ggnome.com/samples/pano2vr_5/tower/ still works fine on the website. Must have been published before 5.1 came out.

Keith

User avatar
Hopki
Gnome
Posts: 7552
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: Toggling Map Issue

Post by Hopki » Mon May 22, 2017 8:30 pm

Hi Keith
Layer Marney Tower was built with 5.0 and the first time animation was available.
Regards,
Hopki

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 2 guests