syntax error in gallery component!

Special forum to share and discuss skins for Pano2VR and Object2VR
Post Reply
petix
Posts: 83
Joined: Wed Feb 02, 2011 9:42 pm

syntax error in gallery component!

Post by petix » Sun Jun 11, 2017 10:06 pm

Hi,

please notice, that there is a syntax error in the gardengnome gallery component that causes flickering images in the gallery. There is a "s" missing at the external loader "gallery_picture". It should be "gallery_pictures". If it's missing you can see the background of the panorama for a while.

Regards
Petix
Attachments
Bildschirmfoto 2017-06-11 um 21.54.54.JPG
Bildschirmfoto 2017-06-11 um 21.54.54.JPG (238.18 KiB) Viewed 243 times
Bildschirmfoto 2017-06-11 um 21.54.07.JPG
Bildschirmfoto 2017-06-11 um 21.54.07.JPG (194.92 KiB) Viewed 243 times

User avatar
Hopki
Gnome
Posts: 7485
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: syntax error in gallery component!

Post by Hopki » Sun Jul 02, 2017 9:34 pm

Hi Petix,
The gallery_picture is the name of the external loader while gallery_pictures is the name of the variable.
The element gallery_picture is actually shown and hidden with a logic block so the ID is not used.
Regards,
Hopki

petix
Posts: 83
Joined: Wed Feb 02, 2011 9:42 pm

Re: syntax error in gallery component!

Post by petix » Sat Jul 08, 2017 2:12 pm

Hi Hopki,

have you tried it out? I´m really estonished that you don't see the difference!

Here are two examples:

http://mesterfoto.de/gnome/without-s/ (background is shining through)
http://mesterfoto.de/gnome/with-s/ (no background)

It took me many hours to find it out, because I wasn' t satisfied with the result of the slideshow from gardengnome. I only changed the -s at the end of the ID gallery_pictures.

Regards
Petix

User avatar
Hopki
Gnome
Posts: 7485
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: syntax error in gallery component!

Post by Hopki » Tue Jul 11, 2017 11:24 pm

Hi Petix,
The way the gallery should work is it will dip to background/screen tint while the image changes.
When it become visible the image would of changed.

The fact the image is not loaded when it opens is a bit odd.
When the gallery is set up correctly the first and second images should be preloaded. This is a feature of this gallery as it preloads each image before it is shown.
This is how the component should work, LINK.

The ID gallery_picture if changed will cause a problem with the gallery_fx timer which will stop the dip to background.
The variable gallery_pictures has no effect with the timer.

The timers actions are:
Activate, Alpha, 0.00, gallery_picture
Deactivate, Alpha, 1.00, gallery_picture

This is the default. If you have changed the actions to target, gallery_pictures, then yes adding the "s" will make it work again.
All I can think is you must have changed the target for the timer for this to effect your gallery.

Try it, download a fresh copy of the gallery and you will see the gallery_fx timers actions.
If your still not convinced can you post your skin.
Regards,
Hopki

petix
Posts: 83
Joined: Wed Feb 02, 2011 9:42 pm

Re: syntax error in gallery component!

Post by petix » Thu Jul 13, 2017 9:30 pm

Hopki wrote:
Tue Jul 11, 2017 11:24 pm
When the gallery is set up correctly the first and second images should be preloaded. This is a feature of this gallery as it preloads each image before it is shown.
This is how the component should work, LINK.

Hi Hopki,

when I have a look at your example I see the mistake or let's say I see what is disturbing me: The background "Image 1" is shining through while fading out the first image und fading in the second image.

Kind regards
Petix

User avatar
Hopki
Gnome
Posts: 7485
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: syntax error in gallery component!

Post by Hopki » Thu Jul 13, 2017 11:48 pm

Hi Petix,
Ok this was by design as I wanted to have a nicer way to change the image in the single image loader.
Dipping it out while it changed was the option I went with as just changing looked ugly.
You could of course make the screen tint a solid colour or use the two external loader skin found in your other post: viewtopic.php?f=13&t=12059
Regards,
Hopki

petix
Posts: 83
Joined: Wed Feb 02, 2011 9:42 pm

Re: syntax error in gallery component!

Post by petix » Sat Jul 15, 2017 3:06 pm

Hi Hopki,

here are my skins from the example above, the only difference between them is the -s after picture.

Have a look. Without -s it's shining through, with -s it is not.

Regards
Petix
Attachments
skin-pictures.ggsk
(10.09 KiB) Downloaded 9 times
skin-picture.ggsk
(10.09 KiB) Downloaded 9 times

User avatar
Hopki
Gnome
Posts: 7485
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: syntax error in gallery component!

Post by Hopki » Sun Jul 16, 2017 12:35 am

Hi Petix
Yes that is right, this is because your braking the skin, the skin was designed to fade out the external loader, then once hidden change the image and then fade back in with the new image. When it is faded out you will see the background.
Changing the ID brakes the the FX timer as it can't fade out the external loader because you have now changed its ID.
So you just see the image change.

With the new two external loader skin you get to 50% visibility of both external loaders as one fades in and the other fades out, so this time you see part of the background.

If you do not want to see anything of the background then change the screen tint to a solid colour.
Regards,
Hopki

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests